Update WordPress on IIS prompts for ftp credentials

After installing WordPress on IIS you get prompted for ftp server and credentials when trying to upgrade WordPress. To fix this error just do the following steps.

In IIS manager

Just give read/write permission to “Authenticated users

  1. Go to Application pools and choose the one used by your WordPress Blog.
  2. Right Click and choose Advanced Settings…
  3. Change the Identity to LocalSystem
  4. Click OK to save changes.

Then on Sites,

  1. Choose your WordPress Blog from the sites list
  2. Right Click on it and click on Edit permissions
  3. Go to security tab and click on Edit… (Group or user names)
  4. Click on add and type “Authenticated users
  5. Click on Check Names to validate the username
  6. Click OK to save changes.

WordPress should update without prompting for ftp credentials.

You may have to enter this into the wp-config.php as well to work properly.

define('FS_METHOD', 'direct');

Leave a Reply